{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2023-5692 in the wild and no public exploit code.","fix":"Upgrade wordpress to 6.5.0 or later.","what":"CVE-2023-5692 is a medium-severity vulnerability in WordPress, published on 5 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-5692 and fix it if it is affected.\n\nWhat it is: CVE-2023-5692 is a medium-severity vulnerability in WordPress, published on 5 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-5692 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 6.5.0\n- wordpress-multisite (Bitnami): affected all versions; fixed in 6.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5692/ (Markdown: https://insights.sbomify.com/CVE-2023-5692/index.md)","id":"CVE-2023-5692","markdown":"https://insights.sbomify.com/CVE-2023-5692/index.md","name":"CVE-2023-5692","record":{"aliases":["BIT-wordpress-2023-5692","BIT-wordpress-multisite-2023-5692","DEBIAN-CVE-2023-5692","GHSA-9m7w-p6hr-xv2x","UBUNTU-CVE-2023-5692"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress Core","requires_auth":"none","summary":"Unauthenticated attackers can expose slugs of custom posts with non-public statuses via a redirect function in WordPress Core.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"WordPress Core is vulnerable to Sensitive Information Exposure in versions up to, and including,  6.4.3 via the redirect_guess_404_permalink function. This can allow unauthenticated attackers to expose the slug of a custom post whose 'publicly_queryable' post status has been set to 'false'.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Core \u003c= 6.4.3 - Sensitive Information Exposure via redirect_guess_404_permalink","id":"CVE-2023-5692","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"CodeAstro Internet Banking System pages_reset_pwd.php sql injection","id":"CVE-2023-5693"},"packages":[{"ecosystem":"Bitnami","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2023-5692"},{"ecosystem":"Bitnami","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2023-5692"}],"prev":{"headline":"Cross-site scripting in Collect.chat Chatbot ⚡️","id":"CVE-2023-5691"},"products":["WordPress"],"published":"2024-04-05","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["WordPress Foundation"]},"summary":"Unauthenticated attackers can expose slugs of custom posts with non-public statuses via a redirect function in WordPress Core.","url":"https://insights.sbomify.com/CVE-2023-5692/"}