# CVE-2023-5692: WordPress Core <= 6.4.3 - Sensitive Information Exposure via redirect_guess_404_permalink

> Unauthenticated attackers can expose slugs of custom posts with non-public statuses via a redirect function in WordPress Core.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2024
- **Updated:** 8 Apr 2026
- **Also known as:** BIT-wordpress-2023-5692, BIT-wordpress-multisite-2023-5692, DEBIAN-CVE-2023-5692, GHSA-9m7w-p6hr-xv2x, UBUNTU-CVE-2023-5692

## What is CVE-2023-5692?

CVE-2023-5692 is a medium-severity vulnerability in WordPress, published on 5 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress Core is vulnerable to Sensitive Information Exposure in versions up to, and including,  6.4.3 via the redirect_guess_404_permalink function. This can allow unauthenticated attackers to expose the slug of a custom post whose 'publicly_queryable' post status has been set to 'false'.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-5692?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 6.5.0 |
| `wordpress-multisite` | Bitnami | All versions | 6.5.0 |

## How do I fix CVE-2023-5692?

Upgrade wordpress to 6.5.0 or later.

## Is CVE-2023-5692 being exploited?

There is no known exploitation of CVE-2023-5692 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5692 and fix it if it is affected.

What it is: CVE-2023-5692 is a medium-severity vulnerability in WordPress, published on 5 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5692 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 6.5.0
- wordpress-multisite (Bitnami): affected all versions; fixed in 6.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5692/ (Markdown: https://insights.sbomify.com/CVE-2023-5692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5692
- OSV: https://osv.dev/vulnerability/CVE-2023-5692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5692/
Summaries are generated and may contain mistakes; the official description above is the record.
