# CVE-2023-5738: WordPress Backup & Migration < 1.4.5 - Subscriber+ Stored XSS

> Subscribers can inject malicious scripts via unsanitized parameters in the WordPress Backup & Migration plugin, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-mgqv-g9mm-hg88

## What is CVE-2023-5738?

CVE-2023-5738 is a medium-severity cross-site scripting vulnerability in Unknown WordPress Backup & Migration, published on 27 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The WordPress Backup & Migration WordPress plugin before 1.4.4 does not sanitise and escape some parameters, which could allow users with a role as low as Subscriber to perform Cross-Site Scripting attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5738?

It affects 1 product.


Products: Webtoffee Backup and Migration.

## How do I fix CVE-2023-5738?

No fix has been published for CVE-2023-5738 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-5738 being exploited?

There is no known exploitation of CVE-2023-5738 in the wild and no public exploit code.

## Other vulnerabilities in Unknown WordPress Backup & Migration

- [CVE-2023-5737](https://insights.sbomify.com/CVE-2023-5737/): WordPress Backup & Migration < 1.4.4 - Subscriber+ Plugin Settings Update (medium 4.3)
- [CVE-2024-31254](https://insights.sbomify.com/CVE-2024-31254/): WordPress WordPress Backup & Migration plugin <= 1.4.7 - Sensitive Data Exposure via Log File vulnerability (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5738 and fix it if it is affected.

What it is: CVE-2023-5738 is a medium-severity cross-site scripting vulnerability in Unknown WordPress Backup & Migration, published on 27 Nov 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-5738 in the wild and no public exploit code.

Affected product: Unknown WordPress Backup & Migration. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5738/ (Markdown: https://insights.sbomify.com/CVE-2023-5738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5738
- OSV: https://osv.dev/vulnerability/CVE-2023-5738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5738/
Summaries are generated and may contain mistakes; the official description above is the record.
