# CVE-2023-5819: Amazonify <= 0.8.1 - Authenticated (Admin+) Stored Cross-Site Scripting

> Administrators can inject scripts into Amazonify settings, affecting multi-site or restricted HTML installations, potentially leading to session hijacking.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Nov 2023
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-hc6p-9rvv-9qq4

## What is CVE-2023-5819?

CVE-2023-5819 is a medium-severity cross-site scripting vulnerability in garykeorkunian Amazonify, published on 7 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The Amazonify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 0.8.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled. However, please note that this can also be combined with CVE-2023-5818 for CSRF to XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5819?

It affects 1 product.


Products: Gara Amazonify.

## How do I fix CVE-2023-5819?

No fix has been published for CVE-2023-5819 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-5819 being exploited?

There is no known exploitation of CVE-2023-5819 in the wild and no public exploit code.

## Other vulnerabilities in garykeorkunian Amazonify

- [CVE-2023-5818](https://insights.sbomify.com/CVE-2023-5818/): Amazonify <= 0.8.1 - Cross-Site Request Forgery to Amazon Tracking ID Update (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5819 and fix it if it is affected.

What it is: CVE-2023-5819 is a medium-severity cross-site scripting vulnerability in garykeorkunian Amazonify, published on 7 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5819 in the wild and no public exploit code.

Affected product: garykeorkunian Amazonify. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5819/ (Markdown: https://insights.sbomify.com/CVE-2023-5819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5819
- OSV: https://osv.dev/vulnerability/CVE-2023-5819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5819/
Summaries are generated and may contain mistakes; the official description above is the record.
