# CVE-2023-5834: Vagrant’s Windows Installer Allowed Directory Junction Write

> Attackers can exploit directory junctions in the Windows installer to perform unauthorized file system writes, potentially leading to privilege escalation or code execution.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2023
- **Updated:** 9 Sep 2024
- **Also known as:** GHSA-47xw-vw6m-w9fq

## What is CVE-2023-5834?

CVE-2023-5834 is a low-severity path traversal vulnerability in HashiCorp Vagrant, published on 27 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

HashiCorp Vagrant's Windows installer targeted a custom location with a non-protected path that could be junctioned, introducing potential for unauthorized file system writes. Fixed in Vagrant 2.4.0.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-1386 (Insecure Operation on Windows Junction / Mount Point)

## Which versions are affected by CVE-2023-5834?

2 open source packages ship an affected version, including github.com/hashicorp/vagrant. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vagrant` | Go | All versions | 2.4.0 |
| `github.com/hashicorp/vagrant` | Go | All versions | 2.4.0 |

Products: Hashicorp Vagrant.

## How do I fix CVE-2023-5834?

Upgrade github.com/hashicorp/vagrant to 2.4.0 or later.

## Is CVE-2023-5834 being exploited?

There is no known exploitation of CVE-2023-5834 in the wild and no public exploit code.

## Other vulnerabilities in HashiCorp Vagrant

- [CVE-2022-42717](https://insights.sbomify.com/CVE-2022-42717/): Privilege escalation in n/a (high 7.8)
- [CVE-2017-16777](https://insights.sbomify.com/CVE-2017-16777/): Privilege escalation in n/a (high 7.8)
- [CVE-2017-16001](https://insights.sbomify.com/CVE-2017-16001/): Race condition in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5834 and fix it if it is affected.

What it is: CVE-2023-5834 is a low-severity path traversal vulnerability in HashiCorp Vagrant, published on 27 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5834 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vagrant (Go): affected all versions; fixed in 2.4.0
- github.com/hashicorp/vagrant (Go): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5834/ (Markdown: https://insights.sbomify.com/CVE-2023-5834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5834
- OSV: https://osv.dev/vulnerability/CVE-2023-5834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5834/
Summaries are generated and may contain mistakes; the official description above is the record.
