{"answers":{"affected":"3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5842 exists.","fix":"Upgrade dolibarr/dolibarr to 16.0.5 or later.","what":"CVE-2023-5842 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 30 Oct 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-5842 and fix it if it is affected.\n\nWhat it is: CVE-2023-5842 is a medium-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 30 Oct 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5842 exists.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 16.0.5\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 16.0.5\n- dolibarr (Bitnami): affected all versions; fixed in 16.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5842/ (Markdown: https://insights.sbomify.com/CVE-2023-5842/index.md)","id":"CVE-2023-5842","markdown":"https://insights.sbomify.com/CVE-2023-5842/index.md","name":"CVE-2023-5842","record":{"aliases":["BIT-dolibarr-2023-5842","GHSA-9pjf-jw9q-fx49"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into Dolibarr, potentially stealing user sessions or executing code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"dolibarr_erp\\/crm","vendor":"dolibarr"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - Stored in GitHub repository dolibarr/dolibarr prior to 16.0.5.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in dolibarr/dolibarr","id":"CVE-2023-5842","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"dolibarr:dolibarr_erp\\/crm","products":["dolibarr:dolibarr_erp\\/crm"],"type":"xss","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Ads by datafeedr.com \u003c= 1.1.3 - Unauthenticated (Limited) Remote Code Execution","id":"CVE-2023-5843"},"packages":[{"ecosystem":"Bitnami","fixed":["16.0.5"],"introduced":["0"],"last_affected":[],"package":"dolibarr","purl":"pkg:bitnami/dolibarr","source":"BIT-dolibarr-2023-5842"},{"ecosystem":"Packagist","fixed":["16.0.5"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-9pjf-jw9q-fx49"},{"ecosystem":"Packagist","fixed":["16.0.5"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-9pjf-jw9q-fx49"}],"prev":{"headline":"OpenEXR Heap Overflow in Scanline Deep Data Parsing","id":"CVE-2023-5841"},"products":["dolibarr/dolibarr"],"published":"2023-10-30","related":[{"cvss_score":9.8,"headline":"Dolibarr vulnerable to privilege escalation","id":"CVE-2022-43138","kev_date_added":null,"published":"2022-11-17"},{"cvss_score":9.8,"headline":"Dolibarr vulnerable to Eval Injection","id":"CVE-2022-40871","kev_date_added":null,"published":"2022-10-12"},{"cvss_score":9.8,"headline":"Dolibarr remote PHP code execution","id":"CVE-2021-33816","kev_date_added":null,"published":"2021-11-10"},{"cvss_score":9.8,"headline":"Dolibarr Improper Restriction of Excessive Authentication Attempts","id":"CVE-2020-7995","kev_date_added":null,"published":"2020-01-26"},{"cvss_score":9.8,"headline":"SQL injection in dolibarr","id":"CVE-2013-2091","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Command injection in dolibarr","id":"CVE-2013-2093","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in product/card.php","id":"CVE-2018-13447","kev_date_added":null,"published":"2018-07-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-06","vendors":["dolibarr"]},"summary":"Attackers can inject malicious scripts into Dolibarr, potentially stealing user sessions or executing code in victim browsers.","url":"https://insights.sbomify.com/CVE-2023-5842/"}