# CVE-2023-5844: Unverified Password Change in pimcore/admin-ui-classic-bundle

> Attackers can change user passwords without verification, leading to account takeover in Pimcore admin interfaces.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2023
- **Updated:** 6 Sep 2024
- **Also known as:** GHSA-6f58-j323-6472

## What is CVE-2023-5844?

CVE-2023-5844 is a medium-severity authentication bypass vulnerability in pimcore/admin-ui-classic-bundle, published on 30 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unverified Password Change in GitHub repository pimcore/admin-ui-classic-bundle prior to 1.2.0.

Weakness: CWE-287 (Improper Authentication), CWE-620 (Unverified Password Change)

## Which versions are affected by CVE-2023-5844?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.0-RC1 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.0-RC1 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2023-5844?

Upgrade pimcore/admin-ui-classic-bundle to 1.2.0-RC1 or later.

## Is CVE-2023-5844 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5844 exists.

## Other vulnerabilities in pimcore/admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5844 and fix it if it is affected.

What it is: CVE-2023-5844 is a medium-severity authentication bypass vulnerability in pimcore/admin-ui-classic-bundle, published on 30 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5844 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.0-RC1
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.0-RC1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5844/ (Markdown: https://insights.sbomify.com/CVE-2023-5844/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5844
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5844
- OSV: https://osv.dev/vulnerability/CVE-2023-5844

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5844/
Summaries are generated and may contain mistakes; the official description above is the record.
