{"answers":{"affected":"3 open source packages ship an affected version, including phpbb/phpbb and phpbb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-5917 in the wild and no public exploit code.","fix":"Upgrade phpbb/phpbb to 3.3.11 or later.","what":"CVE-2023-5917 is a low-severity cross-site scripting vulnerability in phpBB, published on 2 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-5917 and fix it if it is affected.\n\nWhat it is: CVE-2023-5917 is a low-severity cross-site scripting vulnerability in phpBB, published on 2 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-5917 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.3.11\n- phpbb/phpbb (Packagist): affected all versions; fixed in 3.3.11\n- phpbb (Bitnami): affected all versions; fixed in 3.3.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5917/ (Markdown: https://insights.sbomify.com/CVE-2023-5917/index.md)","id":"CVE-2023-5917","markdown":"https://insights.sbomify.com/CVE-2023-5917/index.md","name":"CVE-2023-5917","record":{"aliases":["BIT-phpbb-2023-5917","GHSA-gmx8-8rff-qv6q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"phpBB forum software","requires_auth":"high_privilege","summary":"Remote attackers can inject malicious scripts via the Smiley Pack Handler in phpBB, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"phpbb","vendor":"phpbb"}],"cvss":{"score":2.4,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file phpBB/includes/acp/acp_icons.php of the component Smiley Pack Handler. The manipulation of the argument pak leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpBB Smiley Pack acp_icons.php main cross site scripting","id":"CVE-2023-5917","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":3,"n_references":6,"next":{"headline":"SourceCodester Visitor Management System manage_user.php sql injection","id":"CVE-2023-5918"},"packages":[{"ecosystem":"Bitnami","fixed":["3.3.11"],"introduced":["0"],"last_affected":[],"package":"phpbb","purl":"pkg:bitnami/phpbb","source":"BIT-phpbb-2023-5917"},{"ecosystem":"Packagist","fixed":["3.3.11"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":null,"source":"GHSA-gmx8-8rff-qv6q"},{"ecosystem":"Packagist","fixed":["3.3.11"],"introduced":["0"],"last_affected":[],"package":"phpbb/phpbb","purl":"pkg:composer/phpbb/phpbb","source":"GHSA-gmx8-8rff-qv6q"}],"prev":{"headline":"Lissy93 Dashy Configuration save access control","id":"CVE-2023-5916"},"products":["phpBB"],"published":"2023-11-02","related":[{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-3224","kev_date_added":null,"published":"2008-07-18"},{"cvss_score":10,"headline":"Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to \"two minor security-related bu","id":"CVE-2008-1766","kev_date_added":null,"published":"2008-04-12"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2025-70810","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2001-1471","kev_date_added":null,"published":"2005-04-21"},{"cvss_score":8.1,"headline":"phpBB has Password Reset Link Poisoning via Host Header injection","id":"CVE-2026-29199","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"phpBB arbitrary CSS injection","id":"CVE-2019-16108","kev_date_added":null,"published":"2020-03-19"},{"cvss_score":7.5,"headline":"phpBB Denial of Service","id":"CVE-2019-9826","kev_date_added":null,"published":"2019-05-02"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-27","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts via the Smiley Pack Handler in phpBB, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2023-5917/"}