# CVE-2023-5917: phpBB Smiley Pack acp_icons.php main cross site scripting

> Remote attackers can inject malicious scripts via the Smiley Pack Handler in phpBB, potentially leading to session hijacking or code execution.

- **Severity:** Low 2.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Nov 2023
- **Updated:** 27 Feb 2025
- **Also known as:** BIT-phpbb-2023-5917, GHSA-gmx8-8rff-qv6q

## What is CVE-2023-5917?

CVE-2023-5917 is a low-severity cross-site scripting vulnerability in phpBB, published on 2 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file phpBB/includes/acp/acp_icons.php of the component Smiley Pack Handler. The manipulation of the argument pak leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5917?

3 open source packages ship an affected version, including phpbb/phpbb and phpbb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | All versions | 3.3.11 |
| `phpbb/phpbb` | Packagist | All versions | 3.3.11 |
| `phpbb` | Bitnami | All versions | 3.3.11 |

Products: Phpbb Phpbb.

## How do I fix CVE-2023-5917?

Upgrade phpbb/phpbb to 3.3.11 or later.

## Is CVE-2023-5917 being exploited?

There is no known exploitation of CVE-2023-5917 in the wild and no public exploit code.

## Other vulnerabilities in phpBB

- [CVE-2008-3224](https://insights.sbomify.com/CVE-2008-3224/): Other in n/a (critical 10.0)
- [CVE-2008-1766](https://insights.sbomify.com/CVE-2008-1766/): Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bu (critical 10.0)
- [CVE-2025-70810](https://insights.sbomify.com/CVE-2025-70810/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2001-1471](https://insights.sbomify.com/CVE-2001-1471/): Code injection in n/a (high 8.8)
- [CVE-2026-29199](https://insights.sbomify.com/CVE-2026-29199/): phpBB has Password Reset Link Poisoning via Host Header injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5917 and fix it if it is affected.

What it is: CVE-2023-5917 is a low-severity cross-site scripting vulnerability in phpBB, published on 2 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-5917 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.3.11
- phpbb/phpbb (Packagist): affected all versions; fixed in 3.3.11
- phpbb (Bitnami): affected all versions; fixed in 3.3.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5917/ (Markdown: https://insights.sbomify.com/CVE-2023-5917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5917
- OSV: https://osv.dev/vulnerability/CVE-2023-5917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5917/
Summaries are generated and may contain mistakes; the official description above is the record.
