# CVE-2023-5932: Travelpayouts < 1.1.14 - Reflected XSS

> Reflected XSS in Travelpayouts WordPress plugin allows attackers to execute scripts against admin users, potentially leading to account takeover.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 May 2025
- **Updated:** 16 May 2025
- **Also known as:** GHSA-c9v2-rqm3-3g5r

## What is CVE-2023-5932?

CVE-2023-5932 is a medium-severity cross-site scripting vulnerability in Unknown Travelpayouts: All Travel Brands in One Place, published on 15 May 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Travelpayouts: All Travel Brands in One Place WordPress plugin before 1.1.14 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5932?

It affects 1 product.


Products: Travelpayouts Travelpayouts.

## How do I fix CVE-2023-5932?

No fix has been published for CVE-2023-5932 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-5932 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5932 exists.

## Other vulnerabilities in Unknown Travelpayouts: All Travel Brands in One Place

- [CVE-2023-5934](https://insights.sbomify.com/CVE-2023-5934/): Travelpayouts < 1.1.13 - Settings Update via CSRF (high 7.3)
- [CVE-2024-0337](https://insights.sbomify.com/CVE-2024-0337/): Travelpayouts <= 1.1.15 - Open Redirect (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5932 and fix it if it is affected.

What it is: CVE-2023-5932 is a medium-severity cross-site scripting vulnerability in Unknown Travelpayouts: All Travel Brands in One Place, published on 15 May 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5932 exists.

Affected product: Unknown Travelpayouts: All Travel Brands in One Place. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5932/ (Markdown: https://insights.sbomify.com/CVE-2023-5932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5932
- OSV: https://osv.dev/vulnerability/CVE-2023-5932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5932/
Summaries are generated and may contain mistakes; the official description above is the record.
