CVE-2023-5950 Rapid7 Velociraptor Reflected XSS

High 8.6 Published Updated

Attackers can inject JavaScript into error paths, enabling script execution in user browsers and potential account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-5950?

CVE-2023-5950 is a high-severity cross-site scripting vulnerability in Rapid7 Velociraptor, published on 6 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Rapid7 Velociraptor versions prior to 0.7.0-4 suffer from a reflected cross site scripting vulnerability. This vulnerability allows attackers to inject JS into the error path, potentially leading to unauthorized execution of scripts within a user's web browser. This vulnerability is fixed in version 0.7.0-04 and a patch is available to download. Patches are also available for version 0.6.9 (0.6.9-1).

Weakness: CWE-79

Which versions are affected by CVE-2023-5950?

It affects 1 product.

Products include Rapid7 Velociraptor.

How do I fix CVE-2023-5950?

Upgrade to a fixed version.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-5950 being exploited?

There is no known exploitation of CVE-2023-5950 in the wild and no public exploit code.

Sources

Also known as GHSA-8376-g8hq-hc3j.

Is CVE-2023-5950 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free