# CVE-2023-5950: Rapid7 Velociraptor Reflected XSS

> Attackers can inject JavaScript into error paths, enabling script execution in user browsers and potential account takeover.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2023
- **Updated:** 5 Sep 2024
- **Also known as:** GHSA-8376-g8hq-hc3j

## What is CVE-2023-5950?

CVE-2023-5950 is a high-severity cross-site scripting vulnerability in Rapid7 Velociraptor, published on 6 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rapid7 Velociraptor versions prior to 0.7.0-4 suffer from a reflected cross site scripting vulnerability. This vulnerability allows attackers to inject JS into the error path, potentially leading to unauthorized execution of scripts within a user's web browser. This vulnerability is fixed in version 0.7.0-04 and a patch is available to download. Patches are also available for version 0.6.9 (0.6.9-1).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-5950?

It affects 1 product.


Products: Rapid7 Velociraptor.

## How do I fix CVE-2023-5950?

Upgrade to a fixed version.

## Is CVE-2023-5950 being exploited?

There is no known exploitation of CVE-2023-5950 in the wild and no public exploit code.

## Other vulnerabilities in Rapid7 Velociraptor

- [CVE-2023-0242](https://insights.sbomify.com/CVE-2023-0242/): Insufficient permission check in the VQL copy() function (high 8.8)
- [CVE-2026-5329](https://insights.sbomify.com/CVE-2026-5329/): Rapid7 Velociraptor Improper Input Validation in Client Message Handler (high 8.5)
- [CVE-2026-6290](https://insights.sbomify.com/CVE-2026-6290/): Velociraptor Query() Plugin Misapplies Permissions To Orgs (high 8.0)
- [CVE-2025-14728](https://insights.sbomify.com/CVE-2025-14728/): Rapid7 Velociraptor Directory Traversal Vulnerability (medium 6.8)
- [CVE-2022-35630](https://insights.sbomify.com/CVE-2022-35630/): Unsafe HTML Injection in Artifact Collection Report (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5950 and fix it if it is affected.

What it is: CVE-2023-5950 is a high-severity cross-site scripting vulnerability in Rapid7 Velociraptor, published on 6 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5950 in the wild and no public exploit code.

Affected product: Rapid7 Velociraptor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5950/ (Markdown: https://insights.sbomify.com/CVE-2023-5950/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5950
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5950
- OSV: https://osv.dev/vulnerability/CVE-2023-5950

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5950/
Summaries are generated and may contain mistakes; the official description above is the record.
