CVE-2023-5963 Allocation of Resources Without Limits or Throttling in GitLab

Low 3.1 Published Updated

An attacker can cause a denial of service in GitLab's Advanced Search feature by chaining excessive syntax operators, requiring the Advanced Search feature to be enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-5963?

CVE-2023-5963 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 6 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE with Advanced Search affecting all versions from 13.9 to 16.3.6, 16.4 prior to 16.4.2 and 16.5 prior to 16.5.1 that could allow a denial of service in the Advanced Search function by chaining too many syntax operators.

Weakness: CWE-770

Which versions are affected by CVE-2023-5963?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.9.016.3.6, 16.4.2, 16.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-5963?

Upgrade gitlab to a fixed version for your release line: 16.3.6, 16.4.2 or 16.5.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-5963 being exploited?

There is no known exploitation of CVE-2023-5963 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-5963, GHSA-5rfm-2gcw-59ww.

Is CVE-2023-5963 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free