# CVE-2023-5965: Unrestricted Upload of File with Dangerous Type in EspoCRM

> An authenticated privileged attacker can upload a malicious zip file to execute arbitrary PHP code on the EspoCRM server.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Nov 2023
- **Updated:** 20 Apr 2026
- **Also known as:** BIT-espocrm-2023-5965, GHSA-92xg-872w-r5g2

## What is CVE-2023-5965?

CVE-2023-5965 is a medium-severity vulnerability in EspoCRM, published on 30 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An authenticated privileged attacker could upload a specially crafted zip to the EspoCRM server in version 7.2.5, via the update form, which could lead to arbitrary PHP code execution.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2023-5965?

1 open source package ship an affected version, including espocrm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `espocrm` | Bitnami | All versions | 7.5.2 |

Products: Espocrm Espocrm.

## How do I fix CVE-2023-5965?

Upgrade espocrm to 7.5.2 or later.

## Is CVE-2023-5965 being exploited?

There is no known exploitation of CVE-2023-5965 in the wild and no public exploit code.

Public exploit code:

- PoC for Espo CRM 7.2.4 CVE-2023-5965 & CVE-2023-5966 (github_poc): https://github.com/josemlwdf/CVE-2023-5965

## Other vulnerabilities in EspoCRM

- [CVE-2014-7985](https://insights.sbomify.com/CVE-2014-7985/): Path traversal in n/a (critical 10.0)
- [CVE-2026-33656](https://insights.sbomify.com/CVE-2026-33656/): Path traversal in espocrm (critical 9.1)
- [CVE-2022-38843](https://insights.sbomify.com/CVE-2022-38843/): File upload in n/a (high 8.8)
- [CVE-2019-14351](https://insights.sbomify.com/CVE-2019-14351/): Information disclosure in n/a (high 8.8)
- [CVE-2020-37094](https://insights.sbomify.com/CVE-2020-37094/): EspoCRM 5.7.0 < 5.9.0 - Two-Factor Authentication Bypass via Auth Token Reuse Between Accounts with Identical Passwords (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5965 and fix it if it is affected.

What it is: CVE-2023-5965 is a medium-severity vulnerability in EspoCRM, published on 30 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-5965 in the wild and no public exploit code.

Affected packages and fixed versions:
- espocrm (Bitnami): affected all versions; fixed in 7.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5965/ (Markdown: https://insights.sbomify.com/CVE-2023-5965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5965
- OSV: https://osv.dev/vulnerability/CVE-2023-5965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5965/
Summaries are generated and may contain mistakes; the official description above is the record.
