CVE-2023-5995 Incorrect Authorization in GitLab
An attacker can abuse the policy bot to gain unauthorized access to internal projects in GitLab EE.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-5995?
CVE-2023-5995 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 16.2 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for an attacker to abuse the policy bot to gain access to internal projects.
Weakness: CWE-863
Which versions are affected by CVE-2023-5995?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.2.0 | 16.4.3, 16.5.3, 16.6.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-5995?
Upgrade gitlab to a fixed version for your release line: 16.4.3, 16.5.3 or 16.6.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-5995 being exploited?
There is no known exploitation of CVE-2023-5995 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-5995, GHSA-jgpj-vfxg-97h5.