# CVE-2023-6014: MLflow Authentication Bypass

> Attackers can create arbitrary accounts in MLflow, bypassing authentication and potentially gaining unauthorized access to the platform.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2023
- **Updated:** 4 Sep 2024
- **Also known as:** BIT-mlflow-2023-6014, GHSA-4qq5-mxxx-m6gg, MINI-645h-6m66-485j, PYSEC-2026-415

## What is CVE-2023-6014?

CVE-2023-6014 is a critical authentication bypass vulnerability in Lfprojects Mlflow, published on 16 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An attacker is able to arbitrarily create an account in MLflow bypassing any authentication requirment.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2023-6014?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | None |
| `mlflow` | PyPI | All versions | 2.8.0 |
| `mlflow` | PyPI | All versions | 2.8.0 |
| `mlflow` | PyPI | All versions | 2.8.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2023-6014?

Upgrade mlflow to 2.8.0 or later.

## Is CVE-2023-6014 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6014 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6014 and fix it if it is affected.

What it is: CVE-2023-6014 is a critical authentication bypass vulnerability in Lfprojects Mlflow, published on 16 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6014 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; no fix listed
- mlflow (PyPI): affected all versions; fixed in 2.8.0
- mlflow (PyPI): affected all versions; fixed in 2.8.0
- mlflow (PyPI): affected all versions; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6014/ (Markdown: https://insights.sbomify.com/CVE-2023-6014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6014
- OSV: https://osv.dev/vulnerability/CVE-2023-6014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6014/
Summaries are generated and may contain mistakes; the official description above is the record.
