# CVE-2023-6110: Openstack: deleting a non existing access rule deletes another existing access rule in it's scope

> Attackers can delete unrelated access rules by attempting to delete a non-existent one, compromising identity management integrity.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2024
- **Updated:** 5 Dec 2024
- **Also known as:** DEBIAN-CVE-2023-6110, GHSA-2ppf-2m6f-6v6f, PYSEC-2026-1853, RHSA-2024:2737, RHSA-2024:2769, UBUNTU-CVE-2023-6110, USN-6668-1

## What is CVE-2023-6110?

CVE-2023-6110 is a medium-severity vulnerability in Red Hat OpenStack Platform 16.1, published on 17 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in OpenStack. When a user tries to delete a non-existing access rule in it's scope, it deletes other existing access rules which are not associated with any application credentials.

Weakness: CWE-237 (Improper Handling of Structural Elements)

## Which versions are affected by CVE-2023-6110?

3 open source packages ship an affected version, including python-openstackclient.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-openstackclient` | PyPI | All versions | 6.3.0 |
| `python-openstackclient` | PyPI | All versions | 6.3.0 |
| `python-openstackclient` | PyPI | All versions | 6.3.0 |
| `python-openstackclient` | Red Hat:openstack:17.1::el8 | All versions | 0:5.5.2-17.1.20230829213816.el8ost |
| `python-openstackclient-lang` | Red Hat:openstack:17.1::el8 | All versions | 0:5.5.2-17.1.20230829213816.el8ost |
| `python3-openstackclient` | Red Hat:openstack:17.1::el8 | All versions | 0:5.5.2-17.1.20230829213816.el8ost |
| `python-openstackclient` | Red Hat:openstack:17.1::el9 | All versions | 0:5.5.2-17.1.20230829210830.el9ost |
| `python-openstackclient-lang` | Red Hat:openstack:17.1::el9 | All versions | 0:5.5.2-17.1.20230829210830.el9ost |
| `python3-openstackclient` | Red Hat:openstack:17.1::el9 | All versions | 0:5.5.2-17.1.20230829210830.el9ost |

## How do I fix CVE-2023-6110?

Upgrade python-openstackclient to 6.3.0 or later.

## Is CVE-2023-6110 being exploited?

There is no known exploitation of CVE-2023-6110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6110 and fix it if it is affected.

What it is: CVE-2023-6110 is a medium-severity vulnerability in Red Hat OpenStack Platform 16.1, published on 17 Nov 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-6110 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-openstackclient (PyPI): affected all versions; fixed in 6.3.0
- python-openstackclient (PyPI): affected all versions; fixed in 6.3.0
- python-openstackclient (PyPI): affected all versions; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6110/ (Markdown: https://insights.sbomify.com/CVE-2023-6110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6110
- OSV: https://osv.dev/vulnerability/CVE-2023-6110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6110/
Summaries are generated and may contain mistakes; the official description above is the record.
