CVE-2023-6126 Code Injection in salesagility/suitecrm
Attackers can execute arbitrary code in SuiteCRM via code injection, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-6126?
CVE-2023-6126 is a medium-severity code injection vulnerability in Salesagility Suitecrm, published on 14 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Code Injection in GitHub repository salesagility/suitecrm prior to 7.14.2, 7.12.14, 8.4.2.
Weakness: CWE-94
Which versions are affected by CVE-2023-6126?
1 open source package ship an affected version, including suitecrm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
suitecrm Bitnami | All versions | 7.12.14, 7.14.2, 8.4.2 |
Products include Salesagility Suitecrm.
How do I fix CVE-2023-6126?
Upgrade suitecrm to a fixed version for your release line: 7.12.14, 7.14.2 or 8.4.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-6126 being exploited?
There is no known exploitation of CVE-2023-6126 in the wild and no public exploit code.
Other vulnerabilities in Salesagility Suitecrm
Sources
Also known as BIT-suitecrm-2023-6126, GHSA-q79g-vm3j-m2fc.