CVE-2023-6128 Cross-site Scripting (XSS) - Reflected in salesagility/suitecrm
Reflected Cross-Site Scripting in SuiteCRM allows attackers to execute arbitrary scripts in victim browsers, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-6128?
CVE-2023-6128 is a medium-severity cross-site scripting vulnerability in Salesagility Suitecrm, published on 14 Nov 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Cross-site Scripting (XSS) - Reflected in GitHub repository salesagility/suitecrm prior to 7.14.2, 7.12.14, 8.4.2.
Weakness: CWE-79
Which versions are affected by CVE-2023-6128?
1 open source package ship an affected version, including suitecrm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
suitecrm Bitnami | All versions | 7.12.14, 7.14.2, 8.4.2 |
Products include Salesagility Suitecrm.
How do I fix CVE-2023-6128?
Upgrade suitecrm to a fixed version for your release line: 7.12.14, 7.14.2 or 8.4.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-6128 being exploited?
There is no known exploitation of CVE-2023-6128 in the wild and no public exploit code.
Other vulnerabilities in Salesagility Suitecrm
Sources
Also known as BIT-suitecrm-2023-6128, GHSA-xgv3-h5gf-43h8.