CVE-2023-6147 Possible XXE vulnerability in Jenkins Plugin for Qualys Policy Compliance

Medium 5.7 Published Updated

Authenticated users can exploit missing permission checks to inject XXE payloads via rogue endpoints, leading to data exposure.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-6147?

CVE-2023-6147 is a medium-severity vulnerability in Qualys,Inc. Policy Compliance Connector Jenkins Plugin, published on 9 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access to configure or edit jobs to utilize the plugin and configure potential a rouge endpoint via which it was possible to control response for certain request which could be injected with XXE payloads leading to XXE while processing the response data

Weakness: CWE-611

Which versions are affected by CVE-2023-6147?

2 open source packages ship an affected version, including com.qualys.plugins:qualys-pc. It affects 1 product.

PackageAffectedFixed in
com.qualys.plugins:qualys-pc MavenAll versions1.0.6
com.qualys.plugins:qualys-pc MavenAll versions1.0.6

Products include Qualys Policy Compliance.

How do I fix CVE-2023-6147?

Upgrade com.qualys.plugins:qualys-pc to 1.0.6 or later.

Is CVE-2023-6147 being exploited?

There is no known exploitation of CVE-2023-6147 in the wild and no public exploit code.

Sources

Also known as GHSA-8525-52vg-jv6v.

Is CVE-2023-6147 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free