# CVE-2023-6147: Possible XXE vulnerability in Jenkins Plugin for Qualys Policy Compliance

> Authenticated users can exploit missing permission checks to inject XXE payloads via rogue endpoints, leading to data exposure.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jan 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-8525-52vg-jv6v

## What is CVE-2023-6147?

CVE-2023-6147 is a medium-severity vulnerability in Qualys,Inc. Policy Compliance Connector Jenkins Plugin, published on 9 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access to configure or edit jobs to utilize the plugin and configure potential a rouge endpoint via which it was possible to control response for certain request which could be injected with XXE payloads leading to XXE while processing the response data

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-6147?

2 open source packages ship an affected version, including com.qualys.plugins:qualys-pc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.qualys.plugins:qualys-pc` | Maven | All versions | 1.0.6 |
| `com.qualys.plugins:qualys-pc` | Maven | All versions | 1.0.6 |

Products: Qualys Policy Compliance.

## How do I fix CVE-2023-6147?

Upgrade com.qualys.plugins:qualys-pc to 1.0.6 or later.

## Is CVE-2023-6147 being exploited?

There is no known exploitation of CVE-2023-6147 in the wild and no public exploit code.

## Other vulnerabilities in Qualys,Inc. Policy Compliance Connector Jenkins Plugin

- [CVE-2023-6148](https://insights.sbomify.com/CVE-2023-6148/): Possible XSS vulnerability in Jenkins Plugin for Qualys Policy Compliance (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6147 and fix it if it is affected.

What it is: CVE-2023-6147 is a medium-severity vulnerability in Qualys,Inc. Policy Compliance Connector Jenkins Plugin, published on 9 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-6147 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.qualys.plugins:qualys-pc (Maven): affected all versions; fixed in 1.0.6
- com.qualys.plugins:qualys-pc (Maven): affected all versions; fixed in 1.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6147/ (Markdown: https://insights.sbomify.com/CVE-2023-6147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6147
- OSV: https://osv.dev/vulnerability/CVE-2023-6147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6147/
Summaries are generated and may contain mistakes; the official description above is the record.
