{"answers":{"affected":"2 open source packages ship an affected version, including com.qualys.plugins:qualys-was. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-6149 in the wild and no public exploit code.","fix":"Upgrade com.qualys.plugins:qualys-was to 2.0.12 or later.","what":"CVE-2023-6149 is a medium-severity vulnerability in Qualys,Inc.  Web App Scanning Connector Jenkins Plugin, published on 9 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-6149 and fix it if it is affected.\n\nWhat it is: CVE-2023-6149 is a medium-severity vulnerability in Qualys,Inc.  Web App Scanning Connector Jenkins Plugin, published on 9 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-6149 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.qualys.plugins:qualys-was (Maven): affected all versions; fixed in 2.0.12\n- com.qualys.plugins:qualys-was (Maven): affected all versions; fixed in 2.0.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-6149/ (Markdown: https://insights.sbomify.com/CVE-2023-6149/index.md)","id":"CVE-2023-6149","markdown":"https://insights.sbomify.com/CVE-2023-6149/index.md","name":"CVE-2023-6149","record":{"aliases":["GHSA-5gwh-r76w-934h"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Qualys plugin","requires_auth":"low_privilege","summary":"Authenticated users can exploit an XXE vulnerability in the Qualys Jenkins plugin to read sensitive data or execute code via malicious responses.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Qualys","cpe":[{"product":"web_application_screening","vendor":"qualys"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Qualys Jenkins Plugin for WAS prior to version and including 2.0.11 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access to configure or edit jobs to utilize the plugin and configure potential a rouge endpoint via which it was possible to control response for certain request which could be injected with XXE payloads leading to XXE while processing the response data","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible XXE vulnerability in Jenkins Plugin for Qualys Web Application Security","id":"CVE-2023-6149","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Information Disclosure in Eskom E-municipality","id":"CVE-2023-6150"},"packages":[{"ecosystem":"Maven","fixed":["2.0.12"],"introduced":["0"],"last_affected":[],"package":"com.qualys.plugins:qualys-was","purl":null,"source":"GHSA-5gwh-r76w-934h"},{"ecosystem":"Maven","fixed":["2.0.12"],"introduced":["0"],"last_affected":[],"package":"com.qualys.plugins:qualys-was","purl":"pkg:maven/com.qualys.plugins/qualys-was","source":"GHSA-5gwh-r76w-934h"}],"prev":{"headline":"Possible XSS vulnerability in Jenkins Plugin for Qualys Policy Compliance","id":"CVE-2023-6148"},"products":["Web App Scanning Connector Jenkins Plugin"],"published":"2024-01-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-16","vendors":["Qualys,Inc. "]},"summary":"Authenticated users can exploit an XXE vulnerability in the Qualys Jenkins plugin to read sensitive data or execute code via malicious responses.","url":"https://insights.sbomify.com/CVE-2023-6149/"}