# CVE-2023-6292: Ecwid Ecommerce Shopping Cart < 6.12.5 - Arbitrary Plugin Settings Change via CSRF

> Attackers can force logged-in admins to modify Ecwid plugin settings via CSRF, compromising store configuration integrity.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Jan 2024
- **Updated:** 2 Jun 2025
- **Also known as:** GHSA-wmg5-vm74-qqx4

## What is CVE-2023-6292?

CVE-2023-6292 is a medium-severity vulnerability in Unknown Ecwid Ecommerce Shopping Cart, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Ecwid Ecommerce Shopping Cart WordPress plugin before 6.12.5 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-6292?

It affects 1 product.


Products: Lightspeedhq Ecwid Ecommerce Shopping Cart.

## How do I fix CVE-2023-6292?

No fix has been published for CVE-2023-6292 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-6292 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6292 exists.

## Other vulnerabilities in Unknown Ecwid Ecommerce Shopping Cart

- [CVE-2022-2432](https://insights.sbomify.com/CVE-2022-2432/): Ecwid Ecommerce Shopping Cart <= 6.10.23 - Cross-Site Request Forgery to Settings/Options Update (high 8.8)
- [CVE-2023-24408](https://insights.sbomify.com/CVE-2023-24408/): WordPress Ecwid Shopping Cart Plugin <= 6.11.4 is vulnerable to Cross Site Scripting (XSS) (medium 6.5)
- [CVE-2023-51533](https://insights.sbomify.com/CVE-2023-51533/): WordPress Ecwid Shopping Cart Plugin <= 6.12.4 is vulnerable to Cross Site Request Forgery (CSRF) (medium 5.4)
- [CVE-2024-13795](https://insights.sbomify.com/CVE-2024-13795/): Ecwid by Lightspeed Ecommerce Shopping Cart <= 6.12.27 - Cross-Site Request Forgery to Send Deactivation Message (medium 4.3)
- [CVE-2023-24377](https://insights.sbomify.com/CVE-2023-24377/): WordPress Ecwid Shopping Cart Plugin <= 6.11.3 is vulnerable to Cross Site Request Forgery (CSRF) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6292 and fix it if it is affected.

What it is: CVE-2023-6292 is a medium-severity vulnerability in Unknown Ecwid Ecommerce Shopping Cart, published on 16 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6292 exists.

Affected product: Unknown Ecwid Ecommerce Shopping Cart. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6292/ (Markdown: https://insights.sbomify.com/CVE-2023-6292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6292
- OSV: https://osv.dev/vulnerability/CVE-2023-6292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6292/
Summaries are generated and may contain mistakes; the official description above is the record.
