# CVE-2023-6293: Prototype Pollution in robinbuschmann/sequelize-typescript

> Prototype pollution in sequelize-typescript allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-7pvx-4585-hqww

## What is CVE-2023-6293?

CVE-2023-6293 is a high-severity vulnerability in robinbuschmann/sequelize-typescript, published on 24 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prototype Pollution in GitHub repository robinbuschmann/sequelize-typescript prior to 2.1.6.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2023-6293?

2 open source packages ship an affected version, including sequelize-typescript. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sequelize-typescript` | npm | All versions | 2.1.6 |
| `sequelize-typescript` | npm | All versions | 2.1.6 |

Products: Sequelizejs Sequelize-Typescript.

## How do I fix CVE-2023-6293?

Upgrade sequelize-typescript to 2.1.6 or later.

## Is CVE-2023-6293 being exploited?

There is no known exploitation of CVE-2023-6293 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6293 and fix it if it is affected.

What it is: CVE-2023-6293 is a high-severity vulnerability in robinbuschmann/sequelize-typescript, published on 24 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6293 in the wild and no public exploit code.

Affected packages and fixed versions:
- sequelize-typescript (npm): affected all versions; fixed in 2.1.6
- sequelize-typescript (npm): affected all versions; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6293/ (Markdown: https://insights.sbomify.com/CVE-2023-6293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6293
- OSV: https://osv.dev/vulnerability/CVE-2023-6293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6293/
Summaries are generated and may contain mistakes; the official description above is the record.
