# CVE-2023-6337: Vault May be Vulnerable to a Denial of Service Through Memory Exhaustion When Handling Large HTTP Requests

> Attackers can cause HashiCorp Vault to crash by sending large HTTP requests, exhausting host memory.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-34585, BIT-vault-2023-6337, GHSA-6p62-6cg9-f5f5, GO-2023-2399

## What is CVE-2023-6337?

CVE-2023-6337 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Vault and Vault Enterprise 1.12.0 and newer are vulnerable to a denial of service through memory exhaustion of the host when handling large unauthenticated and authenticated HTTP requests from a client. Vault will attempt to map the request to memory, resulting in the exhaustion of available memory on the host, which may cause Vault to crash.

Fixed in Vault 1.15.4, 1.14.8, 1.13.12.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-6337?

8 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.12.0 | 1.13.12, 1.14.8, 1.15.4 |
| `github.com/hashicorp/vault` | Go | From 1.12.0 | 1.13.12 |
| `github.com/hashicorp/vault` | Go | From 1.12.0 | 1.13.12 |
| `github.com/hashicorp/vault` | Go | From 1.14.0 | 1.14.8 |
| `github.com/hashicorp/vault` | Go | From 1.14.0 | 1.14.8 |
| `github.com/hashicorp/vault` | Go | From 1.15.0 | 1.15.4 |
| `github.com/hashicorp/vault` | Go | From 1.15.0 | 1.15.4 |
| `vault` | Bitnami | From 1.13.0 | 1.13.12, 1.14.8, 1.15.4 |

Products: Hashicorp Vault.

## How do I fix CVE-2023-6337?

Upgrade github.com/hashicorp/vault to a fixed version for your release line: 1.13.12, 1.14.8 or 1.15.4.

## Is CVE-2023-6337 being exploited?

There is no known exploitation of CVE-2023-6337 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6337 and fix it if it is affected.

What it is: CVE-2023-6337 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 8 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6337 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.12.0; fixed in 1.13.12, 1.14.8, 1.15.4
- github.com/hashicorp/vault (Go): affected from 1.12.0; fixed in 1.13.12
- github.com/hashicorp/vault (Go): affected from 1.12.0; fixed in 1.13.12
- github.com/hashicorp/vault (Go): affected from 1.14.0; fixed in 1.14.8
- github.com/hashicorp/vault (Go): affected from 1.14.0; fixed in 1.14.8
- github.com/hashicorp/vault (Go): affected from 1.15.0; fixed in 1.15.4
- github.com/hashicorp/vault (Go): affected from 1.15.0; fixed in 1.15.4
- vault (Bitnami): affected from 1.13.0; fixed in 1.13.12, 1.14.8, 1.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6337/ (Markdown: https://insights.sbomify.com/CVE-2023-6337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6337
- OSV: https://osv.dev/vulnerability/CVE-2023-6337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6337/
Summaries are generated and may contain mistakes; the official description above is the record.
