CVE-2023-6371 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

Attackers can execute arbitrary actions on behalf of victims via stored XSS in GitLab wiki pages.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-6371?

CVE-2023-6371 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 28 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 16.8.5, all versions starting from 16.9 before 16.9.3, all versions starting from 16.10 before 16.10.1. A wiki page with a crafted payload may lead to a Stored XSS, allowing attackers to perform arbitrary actions on behalf of victims.

Weakness: CWE-79

Which versions are affected by CVE-2023-6371?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.8.5, 16.9.3, 16.10.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-6371?

Upgrade gitlab to a fixed version for your release line: 16.8.5, 16.9.3 or 16.10.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-6371 being exploited?

There is no known exploitation of CVE-2023-6371 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-6371, GHSA-h79h-c7qx-243v, UBUNTU-CVE-2023-6371.

Is CVE-2023-6371 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free