# CVE-2023-6379: Cross-site Scripting in Alkacon Software OpenCms

> Remote attackers can inject JavaScript into the Mercury template to hijack user sessions in OpenCms.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Dec 2023
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-w62v-q77r-66cc

## What is CVE-2023-6379?

CVE-2023-6379 is a medium-severity cross-site scripting vulnerability in Alkacon Open CMS, published on 13 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Alkacon Software Open CMS, affecting versions 14 and 15 of the 'Mercury' template. This vulnerability could allow a remote attacker to send a specially crafted JavaScript payload to a victim and partially take control of their browsing session.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-6379?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | From 14.0.0 | 16.0.0 |
| `org.opencms:opencms-core` | Maven | From 14.0.0 | 16.0.0 |

Products: Alkacon Opencms.

## How do I fix CVE-2023-6379?

Upgrade org.opencms:opencms-core to 16.0.0 or later.

## Is CVE-2023-6379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6379 exists.

Public exploit code:

- OpenCMS 14 & 15 - Cross Site Scripting (nuclei): http/cves/2023/CVE-2023-6379.yaml

## Other vulnerabilities in Alkacon Open CMS

- [CVE-2018-8811](https://insights.sbomify.com/CVE-2018-8811/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2019-11819](https://insights.sbomify.com/CVE-2019-11819/): Alkacon OpenCMS CSV Injection via New User module (high 7.8)
- [CVE-2005-4475](https://insights.sbomify.com/CVE-2005-4475/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2024-42699](https://insights.sbomify.com/CVE-2024-42699/): OpenCMS Cross-Site Scripting vulnerability (medium 6.5)
- [CVE-2021-3312](https://insights.sbomify.com/CVE-2021-3312/): XML External Entity Reference in org.opencms:opencms-core (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6379 and fix it if it is affected.

What it is: CVE-2023-6379 is a medium-severity cross-site scripting vulnerability in Alkacon Open CMS, published on 13 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6379 exists.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected from 14.0.0; fixed in 16.0.0
- org.opencms:opencms-core (Maven): affected from 14.0.0; fixed in 16.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6379/ (Markdown: https://insights.sbomify.com/CVE-2023-6379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6379
- OSV: https://osv.dev/vulnerability/CVE-2023-6379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6379/
Summaries are generated and may contain mistakes; the official description above is the record.
