# CVE-2023-6385: WordPress Ping Optimizer <= 2.35.1.3.0 - Log Clearing via CSRF

> Attackers can force logged-in users to clear logs via CSRF due to missing checks in the WordPress Ping Optimizer plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Apr 2024
- **Updated:** 14 Mar 2025
- **Also known as:** GHSA-v74g-7hwm-jpjc

## What is CVE-2023-6385?

CVE-2023-6385 is a medium-severity vulnerability in Unknown WordPress Ping Optimizer, published on 10 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The WordPress Ping Optimizer WordPress plugin through 2.35.1.3.0 does not have CSRF checks in some places, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks such as clearing logs.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-6385?

It affects 1 product.


Products: Wordpress Ping Optimizer Project Wordpress Ping Optimizer.

## How do I fix CVE-2023-6385?

No fix has been published for CVE-2023-6385 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-6385 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6385 exists.

## Other vulnerabilities in Unknown WordPress Ping Optimizer

- [CVE-2022-30705](https://insights.sbomify.com/CVE-2022-30705/): WordPress WordPress Ping Optimizer Plugin <= 2.35.1.2.3 is vulnerable to Cross Site Request Forgery (CSRF) (medium 5.4)
- [CVE-2022-1591](https://insights.sbomify.com/CVE-2022-1591/): WordPress Ping Optimizer < 2.35.1.3.0 - Arbitrary Settings Update via CSRF (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6385 and fix it if it is affected.

What it is: CVE-2023-6385 is a medium-severity vulnerability in Unknown WordPress Ping Optimizer, published on 10 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6385 exists.

Affected product: Unknown WordPress Ping Optimizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6385/ (Markdown: https://insights.sbomify.com/CVE-2023-6385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6385
- OSV: https://osv.dev/vulnerability/CVE-2023-6385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6385/
Summaries are generated and may contain mistakes; the official description above is the record.
