CVE-2023-6386 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An attacker can cause resource exhaustion and service degradation in GitLab instances by exploiting a lack of resource limits.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-6386?

CVE-2023-6386 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 5 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A denial of service vulnerability was identified in GitLab CE/EE, affecting all versions from 15.11 prior to 16.6.7, 16.7 prior to 16.7.5 and 16.8 prior to 16.8.2 which allows an attacker to spike the GitLab instance resource usage resulting in service degradation.

Weakness: CWE-770

Which versions are affected by CVE-2023-6386?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.11.016.6.7, 16.7.5, 16.8.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-6386?

Upgrade gitlab to a fixed version for your release line: 16.6.7, 16.7.5 or 16.8.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-6386 being exploited?

There is no known exploitation of CVE-2023-6386 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-6386, GHSA-vxw5-rxj4-h92f, UBUNTU-CVE-2023-6386.

Is CVE-2023-6386 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free