# CVE-2023-6395: Mock: privilege escalation for users that can access mock configuration

> Attackers with access to mock configuration can inject Jinja2 templates to execute arbitrary code as root on build servers.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2024
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-43540, GHSA-7j98-74jh-cjxh, OESA-2026-3913, OESA-2026-3914, OESA-2026-4061, PYSEC-2026-1949, UBUNTU-CVE-2023-6395

## What is CVE-2023-6395?

CVE-2023-6395 is a medium-severity code injection vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 16 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Mock software contains a vulnerability wherein an attacker could potentially exploit privilege escalation, enabling the execution of arbitrary code with root user privileges. This weakness stems from the absence of proper sandboxing during the expansion and execution of Jinja2 templates, which may be included in certain configuration parameters. While the Mock documentation advises treating users added to the mock group as privileged, certain build systems invoking mock on behalf of users might inadvertently permit less privileged users to define configuration tags. These tags could then be passed as parameters to mock during execution, potentially leading to the utilization of Jinja2 templates for remote privilege escalation and the execution of arbitrary code as the root user on the build server.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-6395?

3 open source packages ship an affected version, including templated-dictionary and templated_dictionary. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `templated-dictionary` | PyPI | All versions | 1.4.1 |
| `templated-dictionary` | PyPI | All versions | 1.4.1 |
| `templated_dictionary` | PyPI | All versions | 1.4.1 |

Products: Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Rpm-Software-Management Mock.

## How do I fix CVE-2023-6395?

Upgrade templated-dictionary to 1.4.1 or later.

## Is CVE-2023-6395 being exploited?

There is no known exploitation of CVE-2023-6395 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Extra Packages for Enterprise Linux

- [CVE-2023-34152](https://insights.sbomify.com/CVE-2023-34152/): Command injection in ImageMagick (critical 9.8)
- [CVE-2022-4170](https://insights.sbomify.com/CVE-2022-4170/): Code injection in rxvt-unicode (critical 9.8)
- [CVE-2022-40315](https://insights.sbomify.com/CVE-2022-40315/): Moodle Minor SQL injection risk in admin user browsing (critical 9.8)
- [CVE-2022-45152](https://insights.sbomify.com/CVE-2022-45152/): Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library (critical 9.1)
- [CVE-2022-24882](https://insights.sbomify.com/CVE-2022-24882/): Server side NTLM does not properly check parameters in FreeRDP (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6395 and fix it if it is affected.

What it is: CVE-2023-6395 is a medium-severity code injection vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 16 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6395 in the wild and no public exploit code.

Affected packages and fixed versions:
- templated-dictionary (PyPI): affected all versions; fixed in 1.4.1
- templated-dictionary (PyPI): affected all versions; fixed in 1.4.1
- templated_dictionary (PyPI): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6395/ (Markdown: https://insights.sbomify.com/CVE-2023-6395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6395
- OSV: https://osv.dev/vulnerability/CVE-2023-6395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6395/
Summaries are generated and may contain mistakes; the official description above is the record.
