# CVE-2023-6460: Information leak in nodejs-firestore

> Developers using the Firestore Node.js library may inadvertently log sensitive API keys, exposing them to anyone with log access.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Dec 2023
- **Updated:** 7 May 2026
- **Also known as:** GHSA-4g6q-77j7-vvjc

## What is CVE-2023-6460?

CVE-2023-6460 is a medium-severity vulnerability in Google nodejs-firestore, published on 4 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A potential logging of the firestore key via logging within nodejs-firestore exists - Developers who were logging objects through this._settings would be logging the firestore key as well potentially exposing it to anyone with logs read access. We recommend upgrading to version 6.1.0 to avoid this issue

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-922 (Insecure Storage of Sensitive Information)

## Which versions are affected by CVE-2023-6460?

2 open source packages ship an affected version, including @google-cloud/firestore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@google-cloud/firestore` | npm | All versions | 6.1.0 |
| `@google-cloud/firestore` | npm | All versions | 6.1.0 |

Products: Google Cloud Firestore.

## How do I fix CVE-2023-6460?

Upgrade @google-cloud/firestore to 6.1.0 or later.

## Is CVE-2023-6460 being exploited?

There is no known exploitation of CVE-2023-6460 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6460 and fix it if it is affected.

What it is: CVE-2023-6460 is a medium-severity vulnerability in Google nodejs-firestore, published on 4 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-6460 in the wild and no public exploit code.

Affected packages and fixed versions:
- @google-cloud/firestore (npm): affected all versions; fixed in 6.1.0
- @google-cloud/firestore (npm): affected all versions; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6460/ (Markdown: https://insights.sbomify.com/CVE-2023-6460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6460
- OSV: https://osv.dev/vulnerability/CVE-2023-6460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6460/
Summaries are generated and may contain mistakes; the official description above is the record.
