# CVE-2023-6476: Cri-o: pods are able to break out of resource confinement on cgroupv2

> An attacker can use an experimental annotation to bypass resource limits, allowing pods to consume all node resources and cause denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2024
- **Updated:** 20 Nov 2025
- **Also known as:** AZL-53405, GHSA-p4rx-7wvg-fwrc, GO-2024-2458, RHSA-2024:0195

## What is CVE-2023-6476?

CVE-2023-6476 is a medium-severity vulnerability in Redhat Openshift Container Platform, published on 9 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in CRI-O that involves an experimental annotation leading to a container being unconfined. This may allow a pod to specify and get any amount of memory/cpu, circumventing the kubernetes scheduler and potentially resulting in a denial of service in the node.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-6476?

7 open source packages ship an affected version, including github.com/cri-o/cri-o. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cri-o/cri-o` | Go | All versions | 1.27.3, 1.28.3, 1.29.1 |
| `github.com/cri-o/cri-o` | Go | All versions | 1.27.3 |
| `github.com/cri-o/cri-o` | Go | All versions | 1.27.3 |
| `github.com/cri-o/cri-o` | Go | From 1.28.0 | 1.28.3 |
| `github.com/cri-o/cri-o` | Go | From 1.28.0 | 1.28.3 |
| `github.com/cri-o/cri-o` | Go | From 1.29.0 | 1.29.1 |
| `github.com/cri-o/cri-o` | Go | From 1.29.0 | 1.29.1 |
| `cri-o` | Red Hat:openshift:4.13::el8 | All versions | 0:1.26.4-6.1.rhaos4.13.git9eb9cf3.el8 |
| `cri-o-debuginfo` | Red Hat:openshift:4.13::el8 | All versions | 0:1.26.4-6.1.rhaos4.13.git9eb9cf3.el8 |
| `cri-o-debugsource` | Red Hat:openshift:4.13::el8 | All versions | 0:1.26.4-6.1.rhaos4.13.git9eb9cf3.el8 |
| `cri-o` | Red Hat:openshift:4.13::el9 | All versions | 0:1.26.4-6.1.rhaos4.13.git9eb9cf3.el9 |
| `cri-o-debuginfo` | Red Hat:openshift:4.13::el9 | All versions | 0:1.26.4-6.1.rhaos4.13.git9eb9cf3.el9 |
| `cri-o-debugsource` | Red Hat:openshift:4.13::el9 | All versions | 0:1.26.4-6.1.rhaos4.13.git9eb9cf3.el9 |

Products: Redhat Openshift Container Platform.

## How do I fix CVE-2023-6476?

Upgrade github.com/cri-o/cri-o to a fixed version for your release line: 1.27.3, 1.28.3 or 1.29.1.

## Is CVE-2023-6476 being exploited?

There is no known exploitation of CVE-2023-6476 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2020-27836](https://insights.sbomify.com/CVE-2020-27836/): Missing authorization in cluster-ingress-operator (critical 9.8)
- [CVE-2018-1085](https://insights.sbomify.com/CVE-2018-1085/): Misconfiguration in openshift-ansible (critical 9.0)
- [CVE-2026-54099](https://insights.sbomify.com/CVE-2026-54099/): Privilege escalation in Red Hat OpenShift Container Platform 4 (high 8.8)
- [CVE-2026-1784](https://insights.sbomify.com/CVE-2026-1784/): Ose-cluster-ingress-operator: remote code execution through haproxy configuration injection (high 8.8)
- [CVE-2021-20182](https://insights.sbomify.com/CVE-2021-20182/): Privilege escalation in openshift (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6476 and fix it if it is affected.

What it is: CVE-2023-6476 is a medium-severity vulnerability in Redhat Openshift Container Platform, published on 9 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6476 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.27.3, 1.28.3, 1.29.1
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.27.3
- github.com/cri-o/cri-o (Go): affected all versions; fixed in 1.27.3
- github.com/cri-o/cri-o (Go): affected from 1.28.0; fixed in 1.28.3
- github.com/cri-o/cri-o (Go): affected from 1.28.0; fixed in 1.28.3
- github.com/cri-o/cri-o (Go): affected from 1.29.0; fixed in 1.29.1
- github.com/cri-o/cri-o (Go): affected from 1.29.0; fixed in 1.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6476/ (Markdown: https://insights.sbomify.com/CVE-2023-6476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6476
- OSV: https://osv.dev/vulnerability/CVE-2023-6476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6476/
Summaries are generated and may contain mistakes; the official description above is the record.
