CVE-2023-6477 Incorrect Privilege Assignment in GitLab
Users with custom admin_group_member permissions can escalate privileges to Owner, requiring GitLab EE administrators to upgrade.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-6477?
CVE-2023-6477 is a medium-severity vulnerability in Gitlab Gitlab, published on 21 Feb 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 16.5 before 16.7.6, all versions starting from 16.8 before 16.8.3, all versions starting from 16.9 before 16.9.1. When a user is assigned a custom role with admin_group_member permission, they may be able to make a group, other members or themselves Owners of that group, which may lead to privilege escalation.
Weakness: CWE-266
Which versions are affected by CVE-2023-6477?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.5.0 | 16.7.6, 16.8.3, 16.9.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-6477?
Upgrade gitlab to a fixed version for your release line: 16.7.6, 16.8.3 or 16.9.1.
Is CVE-2023-6477 being exploited?
There is no known exploitation of CVE-2023-6477 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-6477, GHSA-x645-349v-xwm6, UBUNTU-CVE-2023-6477.