CVE-2023-6489 Inefficient Regular Expression Complexity in GitLab
An attacker can cause service degradation in GitLab by exploiting inefficient regular expressions in the chat integration feature.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-6489?
CVE-2023-6489 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 12 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A denial of service vulnerability was identified in GitLab CE/EE, versions 16.7.7 prior to 16.8.6, 16.9 prior to 16.9.4 and 16.10 prior to 16.10.2 which allows an attacker to spike the GitLab instance resources usage resulting in service degradation via chat integration feature.
Weakness: CWE-1333
Which versions are affected by CVE-2023-6489?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.7.7 | 16.8.6, 16.9.4, 16.10.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-6489?
Upgrade gitlab to a fixed version for your release line: 16.8.6, 16.9.4 or 16.10.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-6489 being exploited?
There is no known exploitation of CVE-2023-6489 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-6489, GHSA-997p-pqq2-w5f5, UBUNTU-CVE-2023-6489.