CVE-2023-6502 Inefficient Regular Expression Complexity in GitLab

Medium 4.3 Published Updated

An attacker can cause a denial of service in GitLab by submitting a crafted wiki page that triggers inefficient regular expression processing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-6502?

CVE-2023-6502 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 23 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Denial of Service (DoS) condition has been discovered in GitLab CE/EE affecting all versions before 16.10.6, version 16.11 before 16.11.3, and 17.0 before 17.0.1. It is possible for an attacker to cause a denial of service using a crafted wiki page.

Weakness: CWE-1333

Which versions are affected by CVE-2023-6502?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.10.6, 16.11.3, 17.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-6502?

Upgrade gitlab to a fixed version for your release line: 16.10.6, 16.11.3 or 17.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-6502 being exploited?

There is no known exploitation of CVE-2023-6502 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-6502, GHSA-9xx7-rp3v-8694, UBUNTU-CVE-2023-6502.

Is CVE-2023-6502 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free