# CVE-2023-6585: JobSearch WP Job Board < 2.3.4 - Arbitrary File Upload to RCE

> Unauthenticated attackers can upload arbitrary files, including PHP, leading to remote code execution on the server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Feb 2024
- **Updated:** 9 Aug 2024
- **Also known as:** GHSA-q25f-2gjj-7ppp

## What is CVE-2023-6585?

CVE-2023-6585 is a high-severity vulnerability in Unknown WP JobSearch, published on 27 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WP JobSearch WordPress plugin before 2.3.4 does not validate files to be uploaded, which could allow unauthenticated attackers to upload arbitrary files such as PHP on the server

## Which versions are affected by CVE-2023-6585?

It affects 1 product.


Products: Eyecix Jobsearch Wp Job Board.

## How do I fix CVE-2023-6585?

No fix has been published for CVE-2023-6585 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-6585 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6585 exists.

## Other vulnerabilities in Unknown WP JobSearch

- [CVE-2024-8615](https://insights.sbomify.com/CVE-2024-8615/): WP JobSearch <= 2.6.7 - Unauthenticated Arbitrary File Upload (critical 10.0)
- [CVE-2024-8614](https://insights.sbomify.com/CVE-2024-8614/): WP JobSearch <= 2.6.7 - Authenticated (Subscriber+) Arbitrary File Upload (critical 9.9)
- [CVE-2024-47636](https://insights.sbomify.com/CVE-2024-47636/): WordPress WP JobSearch plugin <= 2.5.9 - PHP Object Injection vulnerability (critical 9.8)
- [CVE-2024-43931](https://insights.sbomify.com/CVE-2024-43931/): WordPress JobSearch WP Job Board WordPress Plugin plugin <= 2.5.3 - PHP Object Injection vulnerability (critical 9.8)
- [CVE-2021-4361](https://insights.sbomify.com/CVE-2021-4361/): JobSearch WP Job Board <= 1.8.1 - Missing Authorization to Arbitrary Options Update (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6585 and fix it if it is affected.

What it is: CVE-2023-6585 is a high-severity vulnerability in Unknown WP JobSearch, published on 27 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6585 exists.

Affected product: Unknown WP JobSearch. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6585/ (Markdown: https://insights.sbomify.com/CVE-2023-6585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6585
- OSV: https://osv.dev/vulnerability/CVE-2023-6585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6585/
Summaries are generated and may contain mistakes; the official description above is the record.
