CVE-2023-6600 Missing authorization in OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy.

High 8.6 Published Updated

Unauthenticated attackers can modify plugin settings to inject XSS payloads and delete directories due to missing capability checks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-6600?

CVE-2023-6600 is a high-severity missing authorization vulnerability in daanvandenbergh OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy., published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. plugin for WordPress is vulnerable to unauthorized modification of data and Stored Cross-Site Scripting due to a missing capability check on the update_settings() function hooked via admin_init in all versions up to, and including, 5.7.9. This makes it possible for unauthenticated attackers to update the plugin's settings which can be used to inject Cross-Site Scripting payloads and delete entire directories. PLease note there were several attempted patched, and we consider 5.7.10 to be the most sufficiently patched.

Weakness: CWE-79, CWE-862

Which versions are affected by CVE-2023-6600?

It affects 1 product.

Products include Daan Omgf.

How do I fix CVE-2023-6600?

No fix has been published for CVE-2023-6600 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-6600 being exploited?

There is no known exploitation of CVE-2023-6600 in the wild and no public exploit code.

Sources

Also known as GHSA-4c8q-fj5f-25q5.

Is CVE-2023-6600 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free