{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-6600 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-6600 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-6600 is a high-severity missing authorization vulnerability in daanvandenbergh OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy., published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-6600 and fix it if it is affected.\n\nWhat it is: CVE-2023-6600 is a high-severity missing authorization vulnerability in daanvandenbergh OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy., published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-6600 in the wild and no public exploit code.\n\nAffected product: daanvandenbergh OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy.. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-6600/ (Markdown: https://insights.sbomify.com/CVE-2023-6600/index.md)","id":"CVE-2023-6600","markdown":"https://insights.sbomify.com/CVE-2023-6600/index.md","name":"CVE-2023-6600","record":{"aliases":["GHSA-4c8q-fj5f-25q5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can modify plugin settings to inject XSS payloads and delete directories due to missing capability checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"omgf","vendor":"daan"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-862","name":"Missing Authorization"}],"description":"The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. plugin for WordPress is vulnerable to unauthorized modification of data and Stored Cross-Site Scripting due to a missing capability check on the update_settings() function hooked via admin_init in all versions up to, and including, 5.7.9. This makes it possible for unauthenticated attackers to update the plugin's settings which can be used to inject Cross-Site Scripting payloads and delete entire directories. PLease note there were several attempted patched, and we consider 5.7.10 to be the most sufficiently patched.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Missing authorization in OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy.","id":"CVE-2023-6600","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":0,"n_references":4,"next":{"headline":"Ffmpeg: hls unsafe file extension bypass in ffmpeg","id":"CVE-2023-6601"},"packages":[],"prev":{"headline":"Missing Standardized Error Handling Mechanism in microweber/microweber","id":"CVE-2023-6599"},"products":["OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy."],"published":"2024-01-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["daanvandenbergh"]},"summary":"Unauthenticated attackers can modify plugin settings to inject XSS payloads and delete directories due to missing capability checks.","url":"https://insights.sbomify.com/CVE-2023-6600/"}