# CVE-2023-6600: Missing authorization in OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy.

> Unauthenticated attackers can modify plugin settings to inject XSS payloads and delete directories due to missing capability checks.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Jan 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-4c8q-fj5f-25q5

## What is CVE-2023-6600?

CVE-2023-6600 is a high-severity missing authorization vulnerability in daanvandenbergh OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy., published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. plugin for WordPress is vulnerable to unauthorized modification of data and Stored Cross-Site Scripting due to a missing capability check on the update_settings() function hooked via admin_init in all versions up to, and including, 5.7.9. This makes it possible for unauthenticated attackers to update the plugin's settings which can be used to inject Cross-Site Scripting payloads and delete entire directories. PLease note there were several attempted patched, and we consider 5.7.10 to be the most sufficiently patched.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-6600?

It affects 1 product.


Products: Daan Omgf.

## How do I fix CVE-2023-6600?

No fix has been published for CVE-2023-6600 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-6600 being exploited?

There is no known exploitation of CVE-2023-6600 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6600 and fix it if it is affected.

What it is: CVE-2023-6600 is a high-severity missing authorization vulnerability in daanvandenbergh OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy., published on 3 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6600 in the wild and no public exploit code.

Affected product: daanvandenbergh OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy.. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6600/ (Markdown: https://insights.sbomify.com/CVE-2023-6600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6600
- OSV: https://osv.dev/vulnerability/CVE-2023-6600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6600/
Summaries are generated and may contain mistakes; the official description above is the record.
