{"answers":{"affected":"2 open source packages ship an affected version, including phpems/phpems. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-6654 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-6654 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-6654 is a medium-severity unsafe deserialization vulnerability in PHPEMS, published on 10 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-6654 and fix it if it is affected.\n\nWhat it is: CVE-2023-6654 is a medium-severity unsafe deserialization vulnerability in PHPEMS, published on 10 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-6654 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpems/phpems (Packagist): affected from 6.0.0 up to 6.1.3; no fix listed\n- phpems/phpems (Packagist): affected from 6.0.0 up to 6.1.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-6654/ (Markdown: https://insights.sbomify.com/CVE-2023-6654/index.md)","id":"CVE-2023-6654","markdown":"https://insights.sbomify.com/CVE-2023-6654/index.md","name":"CVE-2023-6654","record":{"aliases":["GHSA-5rv2-vvmf-f7w8"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHPEMS","requires_auth":"low_privilege","summary":"Remote attackers can exploit unsafe deserialization in PHPEMS session handling to potentially execute arbitrary code.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"phpems","vendor":"phpems"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A vulnerability classified as critical was found in PHPEMS 6.x/7.x/8.x/9.0. Affected by this vulnerability is an unknown functionality in the library lib/session.cls.php of the component Session Data Handler. The manipulation leads to deserialization. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-247357 was assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2024-02-27","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-02-27T07:50:01Z","kind":"github_poc","ref":"https://github.com/qfmy1024/CVE-2023-6654","stars":2,"title":"CVE-2023-6654 EXP"}],"tier":"poc_unverified"},"has_fix":false,"headline":"PHPEMS Session Data session.cls.php deserialization","id":"CVE-2023-6654","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Hongjing e-HR Login Interface loadhistroyorgtree sql injection","id":"CVE-2023-6655"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["6.0.0"],"last_affected":["6.1.3"],"package":"phpems/phpems","purl":null,"source":"GHSA-5rv2-vvmf-f7w8"},{"ecosystem":"Packagist","fixed":[],"introduced":["6.0.0"],"last_affected":["6.1.3"],"package":"phpems/phpems","purl":"pkg:composer/phpems/phpems","source":"GHSA-5rv2-vvmf-f7w8"}],"prev":{"headline":"PHPGurukul Teacher Subject Allocation Management System Create a new Subject subject.php cross-site request forgery","id":"CVE-2023-6653"},"products":["PHPEMS"],"published":"2023-12-10","related":[{"cvss_score":6.3,"headline":"PHPEMS Purchase Request race condition","id":"CVE-2025-15244","kev_date_added":null,"published":"2025-12-30"},{"cvss_score":6.3,"headline":"PHPEMS index.api.php index deserialization","id":"CVE-2024-1353","kev_date_added":null,"published":"2024-02-09"},{"cvss_score":5.3,"headline":"PHPEMS cross-site request forgery","id":"CVE-2025-15405","kev_date_added":null,"published":"2026-01-01"},{"cvss_score":2.4,"headline":"PHPEMS Content Section api.cls.php cross site scripting","id":"CVE-2023-6472","kev_date_added":null,"published":"2023-12-02"},{"cvss_score":2.3,"headline":"PHPEMS Coupon race condition","id":"CVE-2025-15242","kev_date_added":null,"published":"2025-12-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-28","vendors":["n/a"]},"summary":"Remote attackers can exploit unsafe deserialization in PHPEMS session handling to potentially execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2023-6654/"}