CVE-2023-6680 Improper Certificate Validation in GitLab

High 7.4 Published Updated

Attackers can authenticate as other users via Smartcard if the experimental feature is enabled, requiring an upgrade to GitLab EE.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-6680?

CVE-2023-6680 is a high-severity authentication bypass vulnerability in Gitlab Gitlab, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An improper certificate validation issue in Smartcard authentication in GitLab EE affecting all versions from 11.6 prior to 16.4.4, 16.5 prior to 16.5.4, and 16.6 prior to 16.6.2 allows an attacker to authenticate as another user given their public key if they use Smartcard authentication. Smartcard authentication is an experimental feature and has to be manually enabled by an administrator.

Weakness: CWE-295

Which versions are affected by CVE-2023-6680?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.6.016.4.4, 16.5.4, 16.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-6680?

Upgrade gitlab to a fixed version for your release line: 16.4.4, 16.5.4 or 16.6.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2023-6680 being exploited?

There is no known exploitation of CVE-2023-6680 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-6680, GHSA-wpj8-2grx-f965, UBUNTU-CVE-2023-6680.

Is CVE-2023-6680 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free