# CVE-2023-6681: Jwcrypto: denail of service via specifically crafted jwe

> An attacker can cause a denial of service in applications using JWCrypto by sending crafted JWE tokens that consume excessive computational resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2024
- **Updated:** 26 Feb 2026
- **Also known as:** ALSA-2024:9281, AZL-43006, AZL-43009, DEBIAN-CVE-2023-6681, GHSA-cw2r-4p82-qv79, OESA-2024-1195, OESA-2024-1196, OESA-2024-1197, PYSEC-2024-104, RHSA-2024:9281, RLSA-2024:9281, ROOT-APP-PYPI-CVE-2023-6681, UBUNTU-CVE-2023-6681

## What is CVE-2023-6681?

CVE-2023-6681 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in JWCrypto. This flaw allows an attacker to cause a denial of service (DoS) attack and possible password brute-force and dictionary attacks to be more resource-intensive. This issue can result in a large amount of computational consumption, causing a denial of service attack.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-6681?

3 open source packages ship an affected version, including jwcrypto. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jwcrypto` | PyPI | All versions | 1.5.1 |
| `jwcrypto` | PyPI | All versions | 1.5.1 |
| `jwcrypto` | PyPI | All versions | 1.5.1 |
| `python3-jwcrypto` | AlmaLinux:9 | All versions | 1.5.6-2.el9 |
| `python-jwcrypto` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.5.6-2.el9 |
| `python3-jwcrypto` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.5.6-2.el9 |
| `python-jwcrypto` | Rocky Linux:9 | All versions | 0:1.5.6-2.el9 |

Products: Fedoraproject Fedora, Latchset Jwcrypto, Redhat Enterprise Linux, Redhat Enterprise Linux for Arm 64, Redhat Enterprise Linux for Ibm Z Systems, Redhat Enterprise Linux for Power Little Endian.

## How do I fix CVE-2023-6681?

Upgrade jwcrypto to 1.5.1 or later.

## Is CVE-2023-6681 being exploited?

There is no known exploitation of CVE-2023-6681 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6681 and fix it if it is affected.

What it is: CVE-2023-6681 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6681 in the wild and no public exploit code.

Affected packages and fixed versions:
- jwcrypto (PyPI): affected all versions; fixed in 1.5.1
- jwcrypto (PyPI): affected all versions; fixed in 1.5.1
- jwcrypto (PyPI): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6681/ (Markdown: https://insights.sbomify.com/CVE-2023-6681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6681
- OSV: https://osv.dev/vulnerability/CVE-2023-6681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6681/
Summaries are generated and may contain mistakes; the official description above is the record.
