CVE-2023-6736 Inefficient Regular Expression Complexity in GitLab

Medium 6.5 Published Updated

An attacker can cause client-side denial of service in GitLab by submitting malicious content in the CODEOWNERS file.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-6736?

CVE-2023-6736 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 7 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 11.3 before 16.7.6, all versions starting from 16.8 before 16.8.3, all versions starting from 16.9 before 16.9.1. It was possible for an attacker to cause a client-side denial of service using malicious crafted content in the CODEOWNERS file.

Weakness: CWE-1333

Which versions are affected by CVE-2023-6736?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.3.016.7.6, 16.8.3, 16.9.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-6736?

Upgrade gitlab to a fixed version for your release line: 16.7.6, 16.8.3 or 16.9.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-6736 being exploited?

There is no known exploitation of CVE-2023-6736 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-6736, GHSA-4fr5-6ccq-75w2, UBUNTU-CVE-2023-6736.

Is CVE-2023-6736 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free