CVE-2023-6738 PageLayer <= 1.7.8 - Authenticated(Contributor+) Stored Cross-Site Scripting via meta fields
Authenticated contributors can inject arbitrary scripts via meta fields, leading to stored XSS execution for other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-6738?
CVE-2023-6738 is a medium-severity cross-site scripting vulnerability in softaculous Page Builder: Pagelayer – Drag and Drop website builder, published on 4 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pagelayer_header_code', 'pagelayer_body_open_code', and 'pagelayer_footer_code' meta fields in all versions up to, and including, 1.7.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This appears to be a reintroduction of a vulnerability patched in version 1.7.7.
Which versions are affected by CVE-2023-6738?
It affects 1 product.
Products include Pagelayer Pagelayer.
How do I fix CVE-2023-6738?
No fix has been published for CVE-2023-6738 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-6738 being exploited?
There is no known exploitation of CVE-2023-6738 in the wild and no public exploit code.
Other vulnerabilities in softaculous Page Builder: Pagelayer – Drag and Drop website builder
- CVE-2020-35944 Cross-site request forgery in n/a
- CVE-2020-35947 Missing authorization in n/a
- CVE-2024-30465 WordPress PageLayer plugin <= 1.8.1 - Broken Access Control vulnerability
- CVE-2024-2504 Cross-site scripting in Page Builder: Pagelayer – Drag and Drop website builder
- CVE-2024-2127 Cross-site scripting in Page Builder: Pagelayer – Drag and Drop website builder
Sources
Also known as GHSA-mx69-f24x-8r7c.