# CVE-2023-6805: Server-side request forgery in RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator

> Authenticated contributors can exploit a blind SSRF vulnerability in the Feedzy plugin to make arbitrary web requests and modify internal service data.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Apr 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-x245-wv5c-hr8q

## What is CVE-2023-6805?

CVE-2023-6805 is a medium-severity server-side request forgery vulnerability in themeisle RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator, published on 17 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in all versions up to, and including, 4.4.7 via the fetch_feed functionality. This makes it possible for authenticated attackers, with contributor access and above, to make web requests to arbitrary locations originating from the web application and can be used to modify information from internal services. NOTE: This vulnerability, exploitable by contributor-level users, was was fixed in version 4.4.7. The same vulnerability was fixed for author-level users in version 4.4.8.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-6805?

It affects 1 product.


Products: Themeisle Rss Aggregator by Feedzy.

## How do I fix CVE-2023-6805?

No fix has been published for CVE-2023-6805 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-6805 being exploited?

There is no known exploitation of CVE-2023-6805 in the wild and no public exploit code.

## Other vulnerabilities in themeisle RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator

- [CVE-2024-1317](https://insights.sbomify.com/CVE-2024-1317/): RSS Aggregator by Feedzy <= 4.4.2 - Authenticated(Contributor+) SQL Injection (high 8.8)
- [CVE-2024-1318](https://insights.sbomify.com/CVE-2024-1318/): RSS Aggregator by Feedzy <= 4.4.2 - Missing Authorization to Arbitrary Page Creation and Publication (medium 6.5)
- [CVE-2023-6877](https://insights.sbomify.com/CVE-2023-6877/): Cross-site scripting in RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator (medium 6.4)
- [CVE-2023-6801](https://insights.sbomify.com/CVE-2023-6801/): Cross-site scripting in RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator (medium 6.4)
- [CVE-2023-6798](https://insights.sbomify.com/CVE-2023-6798/): Missing authorization in RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6805 and fix it if it is affected.

What it is: CVE-2023-6805 is a medium-severity server-side request forgery vulnerability in themeisle RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator, published on 17 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6805 in the wild and no public exploit code.

Affected product: themeisle RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6805/ (Markdown: https://insights.sbomify.com/CVE-2023-6805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6805
- OSV: https://osv.dev/vulnerability/CVE-2023-6805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6805/
Summaries are generated and may contain mistakes; the official description above is the record.
