CVE-2023-6813 Login by Auth0 <= 4.6.0 - Reflected Cross-Site Scripting via wle

Medium 6.1 Published Updated

Unauthenticated attackers can inject arbitrary web scripts via the wle parameter, executing code in victim browsers if they click a malicious link.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-6813?

CVE-2023-6813 is a medium-severity cross-site scripting vulnerability in Login by Auth0, published on 10 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The Login by Auth0 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘wle’ parameter in all versions up to, and including, 4.6.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

Weakness: CWE-79

Which versions are affected by CVE-2023-6813?

2 open source packages ship an affected version, including auth0/wordpress.

PackageAffectedFixed in
auth0/wordpress PackagistAll versions4.6.1
auth0/wordpress PackagistAll versions4.6.1

How do I fix CVE-2023-6813?

Upgrade auth0/wordpress to 4.6.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-6813 being exploited?

There is no known exploitation of CVE-2023-6813 in the wild and no public exploit code.

Sources

Also known as GHSA-x6p7-44rh-m3rr.

Is CVE-2023-6813 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free