{"answers":{"affected":"2 open source packages ship an affected version, including auth0/wordpress.","exploited":"There is no known exploitation of CVE-2023-6813 in the wild and no public exploit code.","fix":"Upgrade auth0/wordpress to 4.6.1 or later.","what":"CVE-2023-6813 is a medium-severity cross-site scripting vulnerability in Login by Auth0, published on 10 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-6813 and fix it if it is affected.\n\nWhat it is: CVE-2023-6813 is a medium-severity cross-site scripting vulnerability in Login by Auth0, published on 10 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-6813 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/wordpress (Packagist): affected all versions; fixed in 4.6.1\n- auth0/wordpress (Packagist): affected all versions; fixed in 4.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-6813/ (Markdown: https://insights.sbomify.com/CVE-2023-6813/index.md)","id":"CVE-2023-6813","markdown":"https://insights.sbomify.com/CVE-2023-6813/index.md","name":"CVE-2023-6813","record":{"aliases":["GHSA-x6p7-44rh-m3rr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can inject arbitrary web scripts via the wle parameter, executing code in victim browsers if they click a malicious link.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Login by Auth0 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘wle’ parameter in all versions up to, and including, 4.6.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Login by Auth0 \u003c= 4.6.0 - Reflected Cross-Site Scripting via wle","id":"CVE-2023-6813","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Information Exposure Vulnerability in Cosminexus Component Container","id":"CVE-2023-6814"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"auth0/wordpress","purl":null,"source":"GHSA-x6p7-44rh-m3rr"},{"ecosystem":"Packagist","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"auth0/wordpress","purl":"pkg:composer/auth0/wordpress","source":"GHSA-x6p7-44rh-m3rr"}],"prev":{"headline":"WP Compress – Image Optimizer [All-In-One] \u003c= 6.20.01 - Open Redirect via css","id":"CVE-2023-6812"},"products":["Login by Auth0"],"published":"2024-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["auth0"]},"summary":"Unauthenticated attackers can inject arbitrary web scripts via the wle parameter, executing code in victim browsers if they click a malicious link.","url":"https://insights.sbomify.com/CVE-2023-6813/"}