# CVE-2023-6832: Business Logic Errors in microweber/microweber


- **Severity:** Medium 6.0 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 27 Nov 2024
- **Also known as:** GHSA-qjfx-fvx7-3wvw

## What is CVE-2023-6832?

CVE-2023-6832 is a medium-severity vulnerability in Microweber Microweber, published on 15 Dec 2023. 

### Official description

Business Logic Errors in GitHub repository microweber/microweber prior to 2.0.

Weakness: CWE-840

## Which versions are affected by CVE-2023-6832?

2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `microweber/microweber` | Packagist | All versions | 2.0.0 |
| `microweber/microweber` | Packagist | All versions | 2.0.0 |

Products: Microweber Microweber.

## How do I fix CVE-2023-6832?

Upgrade microweber/microweber to 2.0.0 or later.

## Is CVE-2023-6832 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6832 exists.

## Other vulnerabilities in Microweber Microweber

- [CVE-2022-0558](https://insights.sbomify.com/CVE-2022-0558/): Cross-site Scripting (XSS) - Stored in microweber/microweber (critical 9.8)
- [CVE-2020-23138](https://insights.sbomify.com/CVE-2020-23138/): File upload in n/a (critical 9.8)
- [CVE-2022-0688](https://insights.sbomify.com/CVE-2022-0688/): Business Logic Errors in microweber/microweber (critical 9.4)
- [CVE-2022-0660](https://insights.sbomify.com/CVE-2022-0660/): Generation of Error Message Containing Sensitive Information in microweber/microweber (critical 9.4)
- [CVE-2022-0913](https://insights.sbomify.com/CVE-2022-0913/): Integer Overflow or Wraparound in microweber/microweber (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6832 and fix it if it is affected.

What it is: CVE-2023-6832 is a medium-severity vulnerability in Microweber Microweber, published on 15 Dec 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-6832 exists.

Affected packages and fixed versions:
- microweber/microweber (Packagist): affected all versions; fixed in 2.0.0
- microweber/microweber (Packagist): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6832/ (Markdown: https://insights.sbomify.com/CVE-2023-6832/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6832
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6832
- OSV: https://osv.dev/vulnerability/CVE-2023-6832

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6832/
Summaries are generated and may contain mistakes; the official description above is the record.
