# CVE-2023-6837: Multiple WSO2 products vulnerable to perform user impersonatoin using JIT provisioning

> Attackers can impersonate valid users via JIT provisioning in WSO2 products if specific federated authentication settings are enabled.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 25 Sep 2025
- **Also known as:** GHSA-f6jm-9pr8-9c3w

## What is CVE-2023-6837?

CVE-2023-6837 is a high-severity authentication bypass vulnerability in Wso2 Api Manager, published on 15 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Multiple WSO2 products have been identified as vulnerable to perform user impersonatoin using JIT provisioning. In order for this vulnerability to have any impact on your deployment, following conditions must be met:

  *  An IDP configured for federated authentication and JIT provisioning enabled with the "Prompt for username, password and consent" option.
  *  A service provider that uses the above IDP for federated authentication and has the "Assert identity using mapped local subject identifier" flag enabled.

Attacker should have:

  *  A fresh valid user account in the federated IDP that has not been used earlier.
  *  Knowledge of the username of a valid user in the local IDP.

When all preconditions are met, a malicious actor could use JIT provisioning flow to perform user impersonation.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-6837?

4 open source packages ship an affected version, including org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.authentication.framework and org.wso2.identity.apps:authentication-portal. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.authentication.framework` | Maven | All versions | 5.20.254 |
| `org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.authentication.framework` | Maven | All versions | 5.20.254 |
| `org.wso2.identity.apps:authentication-portal` | Maven | All versions | 1.6.179.1 |
| `org.wso2.identity.apps:authentication-portal` | Maven | All versions | 1.6.179.1 |

Products: Wso2 Api Manager, Wso2 Carbon Identity Application Authentication Endpoint, Wso2 Carbon Identity Application Authentication Framework, Wso2 Identity Server, Wso2 Identity Server as Key Manager.

## How do I fix CVE-2023-6837?

Upgrade org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.authentication.framework to 5.20.254 or later.

## Is CVE-2023-6837 being exploited?

There is no known exploitation of CVE-2023-6837 in the wild and no public exploit code.

## Other vulnerabilities in Wso2 Api Manager

- [CVE-2022-29464](https://insights.sbomify.com/CVE-2022-29464/): WSO2 Multiple Products Unrestrictive Upload of File (critical 9.8, exploited in the wild)
- [CVE-2024-6914](https://insights.sbomify.com/CVE-2024-6914/): Incorrect Authorization in Multiple WSO2 Products via Account Recovery SOAP Admin Service Leading to Account Takeover (critical 9.8)
- [CVE-2020-13226](https://insights.sbomify.com/CVE-2020-13226/): WSO2 API Manager vulnerable to SSRF (critical 9.8)
- [CVE-2025-2905](https://insights.sbomify.com/CVE-2025-2905/): An XML External Entity (XXE) vulnerability in Multiple WSO2 Products (critical 9.1)
- [CVE-2021-42646](https://insights.sbomify.com/CVE-2021-42646/): XML external entity in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6837 and fix it if it is affected.

What it is: CVE-2023-6837 is a high-severity authentication bypass vulnerability in Wso2 Api Manager, published on 15 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6837 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.authentication.framework (Maven): affected all versions; fixed in 5.20.254
- org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.authentication.framework (Maven): affected all versions; fixed in 5.20.254
- org.wso2.identity.apps:authentication-portal (Maven): affected all versions; fixed in 1.6.179.1
- org.wso2.identity.apps:authentication-portal (Maven): affected all versions; fixed in 1.6.179.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6837/ (Markdown: https://insights.sbomify.com/CVE-2023-6837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6837
- OSV: https://osv.dev/vulnerability/CVE-2023-6837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6837/
Summaries are generated and may contain mistakes; the official description above is the record.
