# CVE-2023-6841: Keycloak: amount of attributes per object is not limited and it may lead to dos

> An attacker can cause resource exhaustion and denial of service in Keycloak by sending repeated requests with unlimited attributes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2024
- **Updated:** 8 Nov 2025
- **Also known as:** GHSA-w97f-w3hq-36g2

## What is CVE-2023-6841?

CVE-2023-6841 is a high-severity denial of service vulnerability in Redhat Keycloak, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial of service vulnerability was found in keycloak where the amount of attributes per object is not limited,an attacker by sending repeated HTTP requests could cause a resource exhaustion when the application send back rows with long attribute values.

Weakness: CWE-231 (Improper Handling of Extra Values)

## Which versions are affected by CVE-2023-6841?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 24.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 24.0.0 |

Products: Redhat Keycloak, Redhat Single Sign-On.

## How do I fix CVE-2023-6841?

Upgrade org.keycloak:keycloak-core to 24.0.0 or later.

## Is CVE-2023-6841 being exploited?

There is no known exploitation of CVE-2023-6841 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-6841 and fix it if it is affected.

What it is: CVE-2023-6841 is a high-severity denial of service vulnerability in Redhat Keycloak, published on 10 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-6841 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 24.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 24.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-6841/ (Markdown: https://insights.sbomify.com/CVE-2023-6841/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-6841
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-6841
- OSV: https://osv.dev/vulnerability/CVE-2023-6841

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-6841/
Summaries are generated and may contain mistakes; the official description above is the record.
